"Line plotting not yet supported for Flexlab graphics" Answered

I tried to add extrapolation output, but it couldn't estimate. So, I open the file .flxprt and .flxwrn, It show the warning below.

****warning from gphinp :
Line plotting not yet supported for Flexlab graphics


How can I fix this?


  • A warning should not stop you from estimation or submitting a job. Only an error can do that. Can you please review your *.flxprt file that there are no errors. If none are indicated you might want to submit your job without estimation.

    Comment actions Permalink

    I have to estimate it before running the model on the cloud.

    This is the window that pops up when I click estimate.

    Here is the model syntax error that popped up after I estimated it. So, I opened file .flxprt to find an error.

    But the only error I see is the line that I highlighted.


    So, what can I do next? I struggled with this for a week. Please help me.

    Comment actions Permalink
  • I understand, can you please review your inputs which are highlighted as invalid. 

    Comment actions Permalink
  • My setting is exactly the same as this video clip: "https://www.youtube.com/watch?v=GjS5LRAnzWA&t=1096s".

    Except I added "extrapolation data" in the output with the setting in the picture.

    I'm not sure where I have to look now.

    P.S. My transducer length is 30 mm. I set the cutting point at 31mm.

    Comment actions Permalink
  • Something is incorrect about your model definition. The *.flxprt file states that you have undefined symbol kref. Please open the generated *.flxinp file and review the extr command and its subcommands. You can paste it in your response.,

    Comment actions Permalink
  • Here is the code in file *.flxinp.

    Comment actions Permalink
  • In line 467

    symb #get { * * $kref } clsnode 0. 0 0. $zref

    for the assignment to a variable you are making an assignment to the value stored in the variable instead of the variable. This should instead be

    symb #get { * * kref } clsnode 0. 0 0. $zref

    Are you using Designer for your model, if so, do you mind sharing your Designer model with onscale-support@ansys.com

    Comment actions Permalink
  • Unfortunately, I used OnShape to design the model, but I sent the model and my work to your email. Please take a look. Thank you.

    Comment actions Permalink
  • I changed the code following your advice, but it is still not working, What can I do next? Please help.

    Comment actions Permalink
  • The changes should have resolved that error and the error message should have changed. If you are still having issues, then there is a second separate issue with your model definition. The first place to look would be the *.flxprt file. What does that say?

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post