problem with "your model failed to estimate due to a syntax error". Answered

I just adding one more backing layer under the tutorial of 2D symmetric PZT plate, but the estimation just show me the massage above.

I have read the similar problem like this, but just cannot be solved.

6 comments

  • Official comment

    Hi there,

     

    Welcome to the forum!

     

    You can see what the error is by opening the file generated ending in '-estimate*.flxprt'. The error should be at the bottom of the file. If you need help understanding that error please let me know.

     

    Best Regards,

    Chloe

    Comment actions Permalink
  • Yes, I found that, it shows "No electrode defined". Therefore, I sent you the file to check is anything I set wrong.

    I am quite sure the mesh can cover the voltage load I set.

    Comment actions Permalink
  • Check out this article for what to do for that error - https://support.onscale.com/hc/en-us/articles/360007264097-Troubleshooting-errors

     

    Best Regards,

    Chloe

    Comment actions Permalink
  • Yes. But I checked out and tried the methods, it still not work.

    That's why I share the file to you to hope you can help me.

    Comment actions Permalink
  • The second point in the article is the issue with your model.

    If you are working in Designer and using primitive shapes, check that their precedence is correct and that one is not overwriting another'.

    If you preview your model you will see that it is just water because water has precedence 3 which is the highest. 

    The water is overwriting everything so you need to change the precedence of your shapes in the properties window.

     

    Best Regards,

    Chloe

    Comment actions Permalink
  • Thank you very much Chole! It is solved!

     

    Best regards,

    Kevin

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post