Insufficient Memory Answered

Dear Support,

I am currently running a 2D model which runs fine for my initial settings. I set the system up in the Designer Mode and then switch to Analyst mode to tweak the output results.

However, if I increase the analysis time from 5µs to 25µs the system reports back the "Insufficient memory allocation" error. Changing the memory allocation via the mem command has no effect. The downloaded input file automatically overwrites the mem command to the default settings. I also tried to run withtout the mem command, same result: the downloaded input file again has the default mem command written in the first line.

It seems I am missing an important point regarding the memory managment. Could you please help me to resolve the issue?

 

Error Message:

Memory allocation:     Numeric   data-       117 million  words (       468 Mbyte)     Character data-      2500 thousand words (        50 Mbyte)********************************************************Damping matched at 0.8000000E+08 HzRedefine variable 'freqdamp' if device centre frequencyvaries significantly from this value********************************************************Checking Model Integrity......     **** PZFlex  has detected an error****     ****Subroutines tracked are: cormgr                resdta                jobend                flex                     ****Error occurred in subroutine cormgr                ****     ****Error message****     Insufficient memory allocation for problem     **** PZFlex  has detected an error****     ****Subroutines tracked are: resdta                errend                cormgr                resdta                jobend                flex                     ****Error occurred in subroutine resdta                ****     ****Error message**** name already exists ---- ptmp     WARNING: There were      7     warnings generated during this run1

 

 

3 comments

  • Official comment

    Hi there,

    If you go to the Options (cog in the top right corner) you can set the numerical and character memory in Solver Settings.

    Best Regards,

    Chloe

    Comment actions Permalink
  • Dear Chloe,

    thank you for your advise. Unfortunately the problem persists even if I ramp up the allocated memory considerably  (up to 15 Gig) for just a slight increase in simulation time (5 to 6 µs, 5 works, 6 does not).

    The same issue occurs for another problem I try to run. Also happens while  trying to run it on a machine of a colleague.

    So we are kinda stuck at the moment. Is there another possibility that could cause this issue?

    Best regards,

    Mike

     

     

    Comment actions Permalink
  • Hi Mike,

     

    Your model may be too large to run on your local machine. Have you tried estimating this on the cloud1? If you share your file via your preferred cloud sharing file service I can take a look for you.

    Best Regards,

    Chloe

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post