Your model failed to estimate due to a syntax error in the input deck Answered

Hello,

I have created a simple test model to check OnScale features. However, when I click on "Run on Cloud" and press the button "Estimate", the following message appears: "Your model failed to estimate due to a syntax error in the input deck. Please check your working directory for details within the '.prnt' output file and rectify the issue".

If I press the button "Open output file" nothing happens, and there is no any 'prnt' file in my working folder to check the failure cause.

Does someone knows what could be wrong in the model?

Thank you in advance.

4 comments

  • Official comment

    Hi there,

    Welcome to the forum!

    Just to clarify, the file the error message is talking about has the extension *.flxprt. Is there no such file in your working directory?

     

    Best Regards,

    Chloe.

    Comment actions Permalink
  • Hi Chloe,

    Thank you for your prompt response. Yes, there is a flxprt file (note that the error message referred to a "prnt"). Moreover I realized that OnScale only opened that file from the "Open output file" button once I configured in Windows a default program for its extension (Notepad in this case).

    Inside the flxprt file, the following error message appears:

    **** PZFlex has detected an error****
    ****Subroutines tracked are: chkicr crdinp jobctl flex
    ****Error occurred in subroutine chkicr ****
    ****Error message****
    Grid spacing not monotonic. Use NCHK scom if needed
    0.000000000000000E+00 0.000000000000000E+00

    Regarding the above issue, I found this link. I had not included keypoints in my model and in fact I do not know if they are strictly mandatory (the problem is that they cannot be defined through parameters and restrict parametric analysis).

    I have added keypoints (orderly to avoid non-monoticity) to check if the model now works. However I obtain a similar error message. Looking into the flxprt project, the above error is not present although the following code appears:

    input- keypnt $idx $jdx
    keypoint coordinates not monotonic y3 y4

    Nevertheless my keypoints are ordered:

    Apart from this, the only occurrence of the word "error" in the flxprt file is at the sentence:

     * PZFlex processing suspended-error detected at Thu Feb 20 19:51:54 2020 * 

     

    Do you have any idea on how to solve this problem?

    Thank you.

    Comment actions Permalink
  • Hey there,

    Can you send your input files to us and we can have a look at this for you. It's going to be difficult for us to pinpoint the problem discussing like this.

    Thanks,

    Oliver

    Comment actions Permalink
  • Hey,

    Thanks for sending through your files.

    Any parameter defined in the table that begins with the letter i - n will be set to an integer. Any calculation or floating value will be set to 0.

    You will need to change the variables in the parameter table:

    Kerf, Lx_Piezo, Ly_Piezo, Lx_Matching, Ly_Matching, Lx_Backing, Ly_Backing. These parameters will all need changed. This should fix your problem.

    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post