No electrode node defined problem 回答済み

Hi Onscale support team, I have a question in my simultion

I am now using PZFLEX software to simulate shear stress on the surface of my transducer.

However I faced an error which is listed in figure. I have no idea what is a possible reason that makes error.

Is there and possible reason that can make the magnitude of output pressure rise upto infinity?

I think delta t (calculation frame rate) can be a problem. How can I change a frame rate in PZFLEX?

 

Detail parameters

1. Input signal frequency : 1MHz to 10MHz

2. Input voltage : 100Vpp

3. Input cycle : 10

4. Poling direction : +Z (Where listed in figure 2)

5. Keypoint : -12um, 0um,150um, 178um, 190um, 690um (Z direction)

6. Mesh : 30 element per wavelength ( I tried until 100 element per wavelength also, but it doesn't work)

 

figure 1. Output result (calculated in 300um above the surface of the transducer.)

figure 2. cross section of model (Parylene thickness:12um, Pvdf-trfe thickness:28um, water : 500um, glass : 150um)

 

3件のコメント

  • 正式なコメント

    Hi there,

     

    Welcome to the forum!

     

    The graph shows that your model is going unstable. This could be due to absorbing boundary conditions or bad element aspect ratio. I would recommend switching from absr boundaries to impd as a test. Also have a look at your mesh to ensure there are no long thin elements that could be causing a problem, you want to keypoint the structure for the thin layers.

    Best Regards,

    Chloe.

    コメントアクション Permalink
  • Thank you for kind reply

    I can't see the long thin element. I think this means that keypoints weren't set. How can I fix it?

    Also, I tried changing boundary condition from absorbing to impedance (parameters were set same as water) and result was more stable than before. Thank you

    But i can't understand why absorbing boundary condition can make an error? even I set the impedance parameter same as water (density :1000, velocity: 1496m/s)

    コメントアクション Permalink
  • Hey,

    I think what Chloe previously meant in regards to the thin elements is your paralyne/pvdf layers. So if all of your layers are accounted for then you preview the model then your keypoints are set correctly.

    Here's an article briefly explaining the differences between impdedance and absorbers

     

    Oliver

     

    コメントアクション Permalink

サインインしてコメントを残してください。

お探しのものを見つけられませんでしたか?

新規投稿